Frame Rates Dropping in game

Post Reply
VFS-22_SPaRX
Posts: 61
Joined: Sun Jul 04, 2004 5:00 am

Frame Rates Dropping in game

Post by VFS-22_SPaRX » Sun Jul 04, 2004 2:39 pm

After flying in IL2 Forgotten Battles Aces Exp for a period of time, my FPS in game will drop considerably. If i Disable my Trackir while still in game, my FPS will shoot right back up. Turn it back on then again, my FPS take a HUGE hit. I have spoke with 3 other players that use Trackir and they are seeing the same problem. This only happens when we have been playing the same map for 30-50 minutes or so. Then when the map changes in the game, our FPS will go back to normal. Tonight when this happened to me, i unplugged my Trackir unit while still in game. Waited for the disconnect notice from windows, then reconnected the unit. My FPS stayed normal after i did this. I did not leave the game at any point while disconnecting and reconnecting the unit.

In this group of us, we have Trackir 1 and 2s. We have used 3.10 and 3.11 drivers.

Another issues some of us are getting is that the TRackir will not track smoothly. We have to shut down the software, disconnect then unit, reconnect the unit, then restart the software. For me this happens just about everytime i reboot my computer. I always shut the software down before i reboot.

My systems specs are as follows

Asus A7n8x Mother board
XP2800+ CPU
1 gig of ram
30 gig Maxtor HDD
ATI 9800 Pro Video card.

SPaRX

exos
Posts: 17
Joined: Fri Jun 04, 2004 5:00 am

Re: Frame Rates Dropping in game

Post by exos » Sun Jul 04, 2004 3:29 pm

I'm also one of the people with this problem.
50fps for 30 to 50 minutes, then a sudden drop to 22fps.

After talking with SPaRX, I tried unplugging and replugging as he discovered, and it went back to 50fps.

System specs:
Gigabyte GA-7NNXP
Athlon XP 3200
1 gig ddr
Striped Raid Array
ATI 9800 pro Cat 4.6
TrackIR2 3.10 and 3.11
XP pro sp1

TailFlamer
Posts: 67
Joined: Sun Dec 01, 2002 5:00 am
Location: Hickory, NC USA

Re: Frame Rates Dropping in game

Post by TailFlamer » Sun Jul 04, 2004 3:31 pm

Hi mate

Sorry, but this will really be of no help to you. I just wanted to say that I don't think it is a common problem, I have never experienced it, nor heard of it before. I have played for long sittings and TIR is always on during game play, it is the only view system I use. Never had any slow downs or loss of smooth panning.

I have a TIR 1 using 2.12 software. Maybe try the older software like I am using. Don't know if that will help, but that seems to be the only real difference, so it might be worth a shot.

TailFlamer
Posts: 67
Joined: Sun Dec 01, 2002 5:00 am
Location: Hickory, NC USA

Re: Frame Rates Dropping in game

Post by TailFlamer » Mon Jul 05, 2004 12:01 am

Hi again

Just saw this thread, so maybe it is the software afterall. At least with TIR 1 (possibly TIR 2 as well).

http://forums.naturalpoint.com/cgi-bin/ ... 3&t=000363

Good luck

310thDiablo
Posts: 3
Joined: Mon Jul 05, 2004 5:00 am

Re: Frame Rates Dropping in game

Post by 310thDiablo » Mon Jul 05, 2004 2:32 am

I own the TIR3 Pro and am using drivers 3.11
I have experienced the same thing happening as Sparx but on a much less often. Another problem I seem to be having and not sure if it's TIR or not is that I have been getting blue screens crashes due to hardware and alot of times I see the TIR still turned on even when the software has been shut down. At times when I load IL2 and the TIR program it does not work and I have to unplug and turn the software off and plug it back in and restart the software to get it working again.

specs:
Intel P4 3.2g
1 gig ddr500 OCX ram
ATI 9800se
2x120 gig HDD in array 0
Audigy2
SlipStream Water cooling

[ July 05, 2004, 09:35 AM: Message edited by: 310thDiablo ]

exos
Posts: 17
Joined: Fri Jun 04, 2004 5:00 am

Re: Frame Rates Dropping in game

Post by exos » Mon Jul 05, 2004 6:13 am

quote:Originally posted by Wayne:

exos,

When the frame rate drops, is there a lot happening on the screen at the time. If using Win XP do you have the latest updates on your system.
Including Video, Sound, and Motherboard?
Does IL2 slow down when not using TrackIR?

Wayne,

I've had it happen just sitting on the tarmac, in fact, for the longest time, I thought it was some other drivers or a problem with my system. Then one day when it happened, I turned off TrackIR via F9 key and the framerate jumped back up to 50fps.

At that point I started asking around to see if anyone else experienced this....SPaRX then discovered the unplugging and I varified the same on my system.

When not using TrackIR, I have no loss of framerate.

I have all the latest drivers and XP patches. TrackIR software 3.10 and 3.11 have same symptoms.

I have tested with optimized and default bios settings with the motherboard, with same results. Also with ATI Catalyst 3.7, 4.2, 4.6 drivers.

Motherboard chipset is nforce 2 ultra 400 with the latest drivers from nvidia (Gigabyte recommends using these)

If you have any more questions on specs or drivers, I'll be watching this thread closely.

[EDIT]:

Just discovered when this happens, if I switch to "mouse emulation" framerate comes back, but when I switch back to "trackir enhanced" framerate drops back down.

Thankyou
exos

[ July 05, 2004, 05:13 PM: Message edited by: exos ]

Wayne
Posts: 891
Joined: Thu Jan 08, 2004 5:00 am
Location: Oregon

Re: Frame Rates Dropping in game

Post by Wayne » Mon Jul 05, 2004 5:25 pm

If you are using TrackIR1 we have suggested using the earlier drivers.

exos,

When the frame rate drops, is there a lot happening on the screen at the time. If using Win XP do you have the latest updates on your system.
Including Video, Sound, and Motherboard?
Does IL2 slow down when not using TrackIR?

310thDiablo,

Does this only happen in IL2? Do you have any other games/titles that you could try?

Memory leaks are a good candidate for this type of issue, especially with Windows XP

310thDiablo
Posts: 3
Joined: Mon Jul 05, 2004 5:00 am

Re: Frame Rates Dropping in game

Post by 310thDiablo » Tue Jul 06, 2004 3:27 am

Wayne.....I only use TIR with IL2. Is terhe anything I can do to stop the memory leaks?

Wayne
Posts: 891
Joined: Thu Jan 08, 2004 5:00 am
Location: Oregon

Re: Frame Rates Dropping in game

Post by Wayne » Tue Jul 06, 2004 8:28 am

310thDiablo,

Thanks for letting me know.
I am looking into why this is happening, which appears to be IL2 related.

I do notice that all you guys have ATI cards, this has not happened with the NVIDIA that I have on my system at home. Mmmmmm.

I will test this with an ATI spec system and see what results I come up with.

exos,

Switching to "mouse emulation" is the same as not running the unit as far as IL2 is concerned .....interesting.
Would you be willing to try the 3.10 drivers on your system for me as your system looks ideal to try this?
If you dont have these I can send them to you.

VFS-22_SPaRX
Posts: 61
Joined: Sun Jul 04, 2004 5:00 am

Re: Frame Rates Dropping in game

Post by VFS-22_SPaRX » Tue Jul 06, 2004 12:07 pm

Wayne,

I am still using the 3.10 version drivers. I have not upgraded to the 3.11s as of yet. I get the same problems as Diablo and Exos. I know i have a Trackir 1, but it is happening with all Trackir versions.

S~

SPaRX

Post Reply