Frame Rates Dropping in game

Kosh
Posts: 18
Joined: Sun Jul 24, 2005 5:00 am

Re: Frame Rates Dropping in game

Post by Kosh » Tue Nov 01, 2005 3:57 pm

Hello Rick!

I think I finally have a bit of a diagnostic breakthrough.

What I observed is that the fps slow down seems to be symptomatic of some buffer possibly getting filled.

I managed to capture the moment at which the fps drop and if I F9 at that time and wait a few seconds the fps go back up and stay there for a while and then drop again.

The phenomenon is very similar to a sink being filled faster than it can drain. When you stop the water for a while the sink level drops and you can sustain the flow of water again.

It is the same thing with the TrackIR. When the FPS drops I disable the TrackIR for a good while and resume full tracking also for a while. The longer I keep the TrackIR off the longer I can track after without the FPS loss.

Please forward this info to your techs and ask them to fix it. This problem is affecting a lot more people than are actually posting.

firefly_77
Posts: 1
Joined: Mon Oct 31, 2005 5:00 am

Re: Frame Rates Dropping in game

Post by firefly_77 » Fri Nov 11, 2005 2:36 pm

I am experiencing the exact same problem with the frame rate drops with my Track IR 3 Pro. I lose at least 20 fps with the TIR on.

My TrackIR has a barcode with a number 25527 on it. Could there be a bad lot of chips or something?

Is there any other info I can supply or troubleshooting I can do to help you resolve this problem?

Blaise

Kosh
Posts: 18
Joined: Sun Jul 24, 2005 5:00 am

Re: Frame Rates Dropping in game

Post by Kosh » Sat Nov 12, 2005 6:56 am

The FPS drop sometimes does not occur, it is map related.

I got a new hard drive. Partitioned, formatted, installed XP Pro, newest patches, up to date chipset and video drivers.

TrackIR software version 27.

10 minutes into my Moscow Winter map, WHAP! 25 FPS less. REPEATEDLY.

I just spent $300US on a second 6800GT to SLI my system. My FPS doubled in IL2. Thanks to the TrackIR problem my fps drops to 1/2 or less of the original after a while.

I invested a lot of money in my hardware, then I invested in TrackIR which devalued my hardware.

Thanks to this problem I am getting an FPS equivalent of less than a single 6800.

I spent all this money to play IL2.

I purchased the TrackIR solely for IL2.

Could we please address this problem properly finally? This issue has been brought up on this forum July 4, 2004, OVER a YEAR ago!

I realize that the TrackIR 4 came out, all cool and sexy looking. What do you think is the chance of me buying it or recommending it anyone presently??

Oleg Maddox's Battle Of Brittain is coming out soon and potentially a whole new batch of customers as well.

[ November 12, 2005, 02:04 PM: Message edited by: Kosh Naranek ]

money
Posts: 1
Joined: Sat Nov 12, 2005 5:00 am

Re: Frame Rates Dropping in game

Post by money » Sat Nov 12, 2005 5:20 pm

Has anyone tried the beta 28 drivers for TIR? they seem to have solved the frame drop for me, but only limited testing so far. I was getting about a 10 fps and more drop on version 26, didnt try version 27. on the beta 28 i dont see any drop in fps.

$

[ November 12, 2005, 12:21 PM: Message edited by: money ]

JG27_Stacko
Posts: 1
Joined: Sun Nov 13, 2005 5:00 am
Location: Australia

Re: Frame Rates Dropping in game

Post by JG27_Stacko » Sun Nov 13, 2005 3:50 pm

Yes Rick, I too have the FPS loss issue. I had purchased your great product in Dec '04. I own a TrackIR 3 Pro (barcode: 21539). But I suffer this loss of FPS after playing online for a certain period of time, or after a map change in Il-2+AEP+PF. Every patch since 3.0x I have suffered with this problem.

My System:

AMD 2600+
on a A7N8X-e mobo
1.5 gig of ddr 400 ram
256 mg ATI 9800 pro by Sapphire
Also used to run it on fx5600xt (256) by albatron

I suffer the the FPS loss when I play online for a couple of hours. If i play through a map change I notice the frame drop in about 10 mins - after the change. If I play on the one map it can still happen after about 2-3 hours, but it could be happening in less time.

What do I need to do, Rick? What do you need me to test? I havent really played very much offline, so should I test to see if I can reproduce the effect offline? Is there any specific hardware tests I should make - disable anything or such.

Sir, with respect, u dont throw the baby out with the bath water. I am willing to accept that a product as revolutionary as TrackIR is likely to have teething troubles. I thank Naturalpoint for endeavouring to get to the bottom of this. Maybe its NP, maybe its Oleg/IC/Ubi, maybe Windows or an unforeseen hardware conflict (dunno, TV cards etc or anything could be interfering). Dunno where the problem lies, but I thank-you for trying to fix it.

[ November 13, 2005, 10:51 PM: Message edited by: JG27_Stacko ]

ckur
Posts: 8
Joined: Thu Feb 24, 2005 5:00 am
Location: PORI, Finland

Re: Frame Rates Dropping in game

Post by ckur » Sun Nov 13, 2005 4:09 pm

Hi, posting for a squadmember this time, he bought a new system a got the framedrop wich he did not have with the old system. Thought I'd post those specs here if that should help somehow.

Old system

Prosessor: AMD Athlon 64 3000+ Boxed S754 mobo: DFI LANPARTY UT nF3 250Gb S754
videocard: MSI RX9800PRO-TD128 AGP
memory: Transcend Jetram 512MB DDR 400MHz (x2)
hard drive: Samsung SpinPoint P80 120GB ATA/133 7200

TrackIR 3-pro
Saitek x52

New system

Prosessor -Athlon 64 X2 Boxed 3800+ (0.09) Dual Core, S939, 2.0GHz, 512kB, 2000MHz
mobo -Asus A8N-SLI Deluxe S939
videocard -MSI NX7800GTX-VT2D256E
memory -Kingston KVR400X64C3A/1G 1024Mb DDR 400MHz (x2)
harddrive -Seagate 160 GB, Barracuda 7200.7, 3.5", SATA/150, 8MB, 7200RPM

TrackIR 3-pro
Saitek x52

FSNS_CH

TooCooL34
Posts: 6
Joined: Fri Jul 29, 2005 5:00 am
Location: Seoul, Korea

Re: Frame Rates Dropping in game

Post by TooCooL34 » Sun Nov 13, 2005 9:25 pm

I'm all for this one.
I've been using TrackIR1 & TrackIR2 and had this problem with past 3 different systems.

Current system.
AMD64 winchester 3200+
Chaintech VNF4Ultra(Nforce4 ultra) mobo
Geil DDR 1Gig(2*512) Ram(6-3-3-2.5)
Geforce 6800GT
AudigyDE
MSFFB2
CH Pro throttle & Pro Pedals
TrackIR2. (driver 3.03 and 3.13 has same problem)

If you developers can't reproduce this problem, why don't you set up a system that is exactly same with someone in this post.

Voxman
Posts: 6
Joined: Mon Jan 03, 2005 5:00 am
Location: California

Re: Frame Rates Dropping in game

Post by Voxman » Mon Nov 14, 2005 12:14 am

I too have the same continuing issue and very much the same as described by Stacko.

I'm using TrackIR2

System:
AMD 64+ 3000
DFI Nforce3 250Gb
ATI X800XL
1.5 Gig of Crucial RAM
Audigy 2ZS Sound card

Oh, I see I posted back in January....well its still happening.

[ November 14, 2005, 07:19 AM: Message edited by: Voxman ]

rodom
Posts: 581
Joined: Thu Jul 07, 2005 5:00 am
Location: Philomath, OR

Re: Frame Rates Dropping in game

Post by rodom » Mon Nov 14, 2005 7:03 am

This is still something I am looking into it has not been forgotten. There are several testers as well I will have help with this issue as well.

Coastie
Posts: 6
Joined: Sun Jan 02, 2005 5:00 am

Re: Frame Rates Dropping in game

Post by Coastie » Mon Nov 14, 2005 7:51 am

I too have this problem. Just the other night online I had my FPS drop from 60-70 avg to 30-40 and sometimes lower. Disable TIR and FPS go back to normal.

This only occurs after extended play in one server. You must stay in server for at least an hour to give it a good chance. It will surely happen within 2 hours and a map change.

TIR2 w/v-3.13 driver

AMD 2800+ @2312mhz
1gb PC3200 ram
Sapphire ATI X800XL agp
Audigy2
MSFFB2
Klipsch promedia 2.1 speakers

I will gladly help NP figure this out by using some debug software if available.

Just let me know!

Coastie

Post Reply