Frame Rates Dropping in game

Murph50
Posts: 9
Joined: Sun Dec 12, 2004 5:00 am
Location: Denver,CO,USA

Re: Frame Rates Dropping in game

Post by Murph50 » Thu Jan 13, 2005 12:17 pm

I reccomend rebooting your PC if you have been doing anything else with it before running Il2, especially if you have been using a web browser. It does'nt fix things entirely, but I have seen improvement in the freeze problem when I do this.
There is also a tool out there that allows adjustment of your vidcard's latency, it seems to "smooth" things out a bit. Just some things that have worked for me.

Macel
Posts: 1
Joined: Wed Jan 26, 2005 5:00 am
Location: CT

Re: Frame Rates Dropping in game

Post by Macel » Wed Jan 26, 2005 8:31 am

Having a little experience with java... There might be some problem with the java virtual machine, or the way the IL2 code deals with the java virtual machine if these framerate drops are not connected with memory usage and/or increased processor usage...

Wayne
Posts: 891
Joined: Thu Jan 08, 2004 5:00 am
Location: Oregon

Re: Frame Rates Dropping in game

Post by Wayne » Wed Jan 26, 2005 11:30 am

Guys,

I am working very closely with VFS-22_SPaRX on this, so any findings that we make we will post in here.

Thats if I can stay in the air long enough to find out.... Some of you guys out there must live, eat and sleep IL2.

BM457_Hellbender
Posts: 14
Joined: Mon Nov 29, 2004 5:00 am

Re: Frame Rates Dropping in game

Post by BM457_Hellbender » Wed Feb 02, 2005 2:35 am

You know, I have an additional problem I never mentioned, since it's really easy for me to solve, but it might have something to do with the framerate drop.

Basically, the TrackIR software (still using v3.13 since it has mouse emulation) crashes every time I first run it. All I have to do is run it a second time, and I'm good to go.

Now, I tried out v4, and didn't experience said problem. Too bad I can't actually use it; mouse emulation has saved me more than once in a particularly bad drop.

Best of luck locating the issue. As for me, I'm at your disposal if you need me to test out some of your findings. At this point, I just want the madness to end and start enjoying TrackIR to its fullest.

BM457_Hellbender
Posts: 14
Joined: Mon Nov 29, 2004 5:00 am

Re: Frame Rates Dropping in game

Post by BM457_Hellbender » Thu Feb 03, 2005 11:25 am

This is the Java error that seems to be combined with the framerate drop. It's repeated continously (like, every tenth of a second or so).

http://users.skynet.be/67/pf/trackirerr.gif

I'm sending this to Maddox, too.

Wayne
Posts: 891
Joined: Thu Jan 08, 2004 5:00 am
Location: Oregon

Re: Frame Rates Dropping in game

Post by Wayne » Thu Feb 03, 2005 6:02 pm

BM357_Hellbender,

Thanks for sending this through. I have had one or two of our users looking at this because the game is actually built on java engine.

BM457_Hellbender
Posts: 14
Joined: Mon Nov 29, 2004 5:00 am

Re: Frame Rates Dropping in game

Post by BM457_Hellbender » Tue Feb 08, 2005 6:35 pm

It's back up now.

Anything that might be of help...

BM457_Hellbender
Posts: 14
Joined: Mon Nov 29, 2004 5:00 am

Re: Frame Rates Dropping in game

Post by BM457_Hellbender » Fri Feb 11, 2005 6:17 pm

Realistically, is there any hope of seeing a solution to this problem? Has the source been located yet? I'm very willing to believe it has got nothing to do with the TrackIR software.

ckur
Posts: 8
Joined: Thu Feb 24, 2005 5:00 am
Location: PORI, Finland

Re: Frame Rates Dropping in game

Post by ckur » Wed Feb 23, 2005 6:30 pm

Chalk up one more having the frame drop with FB+AEP+PF merged. I fly quite a lot on Virtualpilots_1 server and last night I made a flight of about 45 mins without even seeing anyone. I noticed that frames were around or under 30 and when I turned Tir 3Pro off they jumped to 50+. After landing restarted both track ir software and IL and the frames were back up again using Tir or not. I tried unplugging the device and re-plugging it, but that did not have any effect. I will try setting the priority and see if it has affect or not and report the results if any.

Edit: using Tir software version 4.0.022

My system:
AMD 64 3200+, Saphire Radeon 9800 Pro, 1,5 Gb Kinston, Abit K8V mobo, integrated soundcard, SB 5100, Saitek X45 joystick, Track ir 3Pro

[ February 24, 2005, 01:35 AM: Message edited by: ckur ]

VFS-22_SPaRX
Posts: 61
Joined: Sun Jul 04, 2004 5:00 am

Re: Frame Rates Dropping in game

Post by VFS-22_SPaRX » Thu Feb 24, 2005 1:37 pm

Ok, i think i may have found the culprit. Tonight i turned off AF in my control panel and S3TC compression in IL2 setup. I played 3 maps and did not get the framerate drop. Someone at UBI forums said taht he was getting the framerate drop with 2x AA and 0x AF, so i think we can rule out AF being an the problem. Only thing left is the S3TC compression that i disabled.

So all of you that are having this problem, do you have S3TC compression enabled? If so, try running with it disabled and see if that fixes the problem.

BTW guys, I got the framerate drops on both ATI and Nvidia cards as well. I have tested this on just the ATI card. Time premiiting i will try the Nvidia card as well.

S~

SPaRX

[ February 24, 2005, 08:40 PM: Message edited by: VFS-22_SPaRX ]

Post Reply