Track IR 4 Pro and FSX Lag

VincentG
Posts: 7728
Joined: Mon Jul 17, 2006 5:00 am
Location: Corvallis, Oregon

Re: Track IR 4 Pro and FSX Lag

Post by VincentG » Mon Mar 19, 2007 12:34 pm

Thanks for the input, and keep me up to date..........

troppo1
Posts: 17
Joined: Tue Mar 13, 2007 12:28 pm

Update on Lag Prob

Post by troppo1 » Fri Mar 30, 2007 12:02 am

After trying everything the solution was as follows:
.
Run FileMon and see if your getting NAME COLLISIONS while idle and while flying.
This was caused by my Wireless network card drivers/software. It was making a Folder Called Provisions and was always looking for a file in the folder that didnt exist, thus causing a bottleneck and slowing the network down..
Took out the wireless card and hooked a Crossover cable into my dowload pc and get my internet from there.
My flying PC has only FSX on it, nothing else.
The Firewall is on but I have deleted the antivirus and as I only use internet while online flying I install the antivirus, scan the pc, use C Cleaner, Adaware, uninstall the antivirus again and Defrag .
The Network seams to be the cause of all probs, something to do with TCP/IP packet bottlenecks or not enough bandwith.

I now run Fsuicp registered with WideFS ((running Flightsim Commander 8.0 on the 2nd download pc with Google, MSN Messenger and Teamspeak)). TrackIR and I-Vibe on the flying Pc with Abacus EZ-gps on the flying pc's second screen ( Great for seeing Multiplayer and AI traffic on the Radar Page).
As long as I keep the network bandwith and the internet bandwith as free as possable it is OK, not great but better than before. If it starts to freeze and get stuttery there is nothing I can do but reboot to get it smooth again.

The second solution works really well but is very expensive:

Only fly with Swiss VFR Pro and UK VFR scenery as this is photo scenery and it automatically turns the AutoGen OFF giving a lot more power to FSX.
I virtually only fly now in Switzerland because 1: The scenery is fantastic and 2: Autogen is off and I dont get the stutters, (not a network prob but a performance prob)and I can run everything and still pan smoothly.
The only other advice is to wait until the Patch comes out and hope it helps.

VincentG
Posts: 7728
Joined: Mon Jul 17, 2006 5:00 am
Location: Corvallis, Oregon

Re: Update on Lag Prob

Post by VincentG » Fri Mar 30, 2007 10:02 am

I think that SP1, for FSX, will help out; and thanks for the update. I will add it to my list of FSX tools.....

spotlope
Posts: 32
Joined: Thu Mar 25, 2004 5:00 am
Location: Portland, Oregon USA

Re: Update on Lag Prob

Post by spotlope » Fri May 25, 2007 8:20 am

I think that SP1, for FSX, will help out; and thanks for the update. I will add it to my list of FSX tools.....
I'm still getting random lags with SP1. It seems to happen primarily with addon aircraft that are complex and taxing to the system. The Wings of Power II B-17 is a prime culprit, as are the Eaglesoft Cirrus SR22 and Columbia 400. I've done some experimenting, and it seems that if I can get the TrackIR working right (no movement lag), it will stay smooth as long as I don't pause the simulator, or switch to the 2D panel. If either of those things happen, I run the risk of lags developing again. Curiously, once the TIR is laggging, even changing to a simple default airplane like the 172 won't clear it up. Last night I was flying the Columbia 400, and discovered that I could often get rid of the lag in the VC by loading the 2D panel and then popping back to VC. Curious. If it's smooth, loading the 2D panel will sometimes cause lags; if it's lagging, the same action will sometimes get rid of them. Whatever the problem is, I seldom fly in FSX without experiencing it.

spotlope
Posts: 32
Joined: Thu Mar 25, 2004 5:00 am
Location: Portland, Oregon USA

Re: Update on Lag Prob

Post by spotlope » Mon Jun 25, 2007 8:53 am

This is just a tweak, to try and get someone's attention here again. Have we had any progress on figuring out why the lag problem is still happening in FSX SP1? It's starting to become more prevalent on my sim, and is really killing the enjoyment of TrackIR. I've heard that problems with TCP/IP and name collisions have been suggested, but nobody's proposed a solution that I've seen.

Heads up: this is still a problem in SP1, and if anything it seems to be getting worse. It'd be good to know that someone at NaturalPoint is working on a solution.

thanks,
Bill Womack

VincentG
Posts: 7728
Joined: Mon Jul 17, 2006 5:00 am
Location: Corvallis, Oregon

Re: Update on Lag Prob

Post by VincentG » Mon Jun 25, 2007 12:52 pm

You could try increasing the "Set Priority" for the TrackIR software, within the Task Manager -> Processes Tab -> Right click on the TrackIR.exe file -> Set Priority to AboveNormal....

See if that helps.....

Parksy
Posts: 7
Joined: Tue Nov 22, 2005 5:00 am

Re: Update on Lag Prob

Post by Parksy » Thu Jun 28, 2007 4:24 pm

I'm back.
Brand new TrackIr 4 with clip arrived today and FSX is a no go cause of the lag. Results are exactly as with my 3 w/ vector. Was hoping the 4 with SP1 would get me going in FSX but I guess it's back to square one. I'll plow thru this post and others ( again ) and try to work this out myself. If ANYTHING else comes up please let me ( us ) know.




Greg

Asus A8N
Athlon 64 3500
ATI 9800 Pro 256
1 gig RAM
Windows XP SP2

VincentG
Posts: 7728
Joined: Mon Jul 17, 2006 5:00 am
Location: Corvallis, Oregon

Re: Update on Lag Prob

Post by VincentG » Thu Jun 28, 2007 4:39 pm

What framerates are you getting?

Parksy
Posts: 7
Joined: Tue Nov 22, 2005 5:00 am

Re: Update on Lag Prob

Post by Parksy » Thu Jun 28, 2007 5:48 pm

What framerates are you getting?


Well, even though my rig is dated, I adjust sliders and get between 10-20 FPS in FSX with SP1.

So here's the strange part. I can fly the Carenado Cessna 206 in FSX using TrackIR and have almost no lag. In fact I just finished a very enjoyable mountain flight. But all default, and all other payware aircraft produce this lag.
Just for clarification, lag time is well over ten seconds per head movement, not just stutters ( I could live with that)....

So why only the Carenado ??? Wierd eh.

All works perfect in FS9 BTW.

cheers

Greg

spotlope
Posts: 32
Joined: Thu Mar 25, 2004 5:00 am
Location: Portland, Oregon USA

Re: Update on Lag Prob

Post by spotlope » Thu Jun 28, 2007 10:21 pm

You could try increasing the "Set Priority" for the TrackIR software, within the Task Manager -> Processes Tab -> Right click on the TrackIR.exe file -> Set Priority to AboveNormal....

See if that helps.....
I tried following your suggestion tonight, Vincent. It worked! Bumping up TIR's priority to AboveNormal completely eliminated the lag in FSX, no matter what aircraft I was flying. I really stressed it, too, with high slider values and demanding planes. The frame rates dropped pretty badly in some scenarios, but the TrackIR never once lagged. This was an excellent suggestion for my rig. I hope it works for others.

thanks,
Bill

Post Reply