Page 1 of 1

Strange TIR 5/TCP v5 beta 2 behaviour

Posted: Tue Jun 02, 2009 1:07 am
by meditek
Everything was working fine previously until I went online last night. From the word go things were fouled up :-

1. Everything was jerky. When I centered TIR my KP8 forward view came up! If I nodded my head very slightly it flicked into 'TIR view'. The same was happening with ALL my FOV's - constantly jumping between my AH keypad views and TIR. TIR had lost complete view control.

2. When I attacked a plane I got unwanted zoom and stuck there.

3. I went offline, reloaded TIR and AH and the problem remained.

I hadn't changed any of the settings since it worked properly. I fly with a 24" 1920 x 1200 monitor with AH FOV set at 110 which has the effect of pushing me back in the cockpit. However, things had worked fine previously at 110.

The feeling I have is that AH will only allow TIR to take full control within certain parameters which have not been fully addressed for widescreen monitors. I should be interested in your view.


EDIT :- I think I have discovered the cause of the problem. I had disabled the Z axis. The above problem is consistent when the Z axis is disabled. However, I do not want the Z-axis as it is more of a nuisance than a help to me. It would seem that AH is looking for a Z-axis and throws a wobbler when it cannot find it.

EDIT_2 :- Oh no! Now everything is working fine with Z disabled and AH FOV at 110 just as it was until last night. It would seem that the problem is intermittent - the worst possible scenario. I have changed nothing. I have not unloaded any other programs or rebooted etc etc. The only thing I did do was to exit the 5 software, load the 4 software to see if the problem happened there (it didn't but unless I moved very close to the TIR unit, tracking was terrible), unload the 4 and reload the 5.

EDIT_3 :- Whilst testing the Zoom problem posted by Squash I discovered that turning off x and y (z was already off) caused the exact same problem to recur. Moreover, when I unloaded AH, set TIR back to X and Y on, AH would not reload! I suspect the cause of this problem may well be a memory leak because, after re-booting, everything worked fine.

EVGA nforce 750i SLI mainboard
Intel Core2 Duo E8500 @3.8MHz
4gb DDR2 PC2-6400 Corsair Ram
750W PSU
Nvidia Geforce 9800GTX+ 185.85 drivers
Benq 1920x1200 FP241q monitor
logitech G9 mouse
Logitech G15 keyboard
Windows Vista x64
Thrustmaster Hotas Cougar + uber 2 conversion + Hall sensors
Simped rudder pedals
TrackIR 5 + Trackclip Pro (beta 2 software)
AH settings maxed

Re: Strange TIR 5/TCP v5 beta 2 behaviour

Posted: Tue Jun 02, 2009 9:55 am
by VincentG
Have you tried the latest beta version of the software?

Re: Strange TIR 5/TCP v5 beta 2 behaviour

Posted: Tue Jun 02, 2009 2:16 pm
by meditek
No. It seemed from comments to cause more problems than it solved and the list of 'improvements' seemed minimal. Are you saying that there are other improvements not mentioned in the update? It is always nice to see a full list of changes when new software emerges.

Re: Strange TIR 5/TCP v5 beta 2 behaviour

Posted: Wed Jun 03, 2009 12:50 am
by meditek
I have now tried version 3 and there is no difference. The problem remains.

Re: Strange TIR 5/TCP v5 beta 2 behaviour

Posted: Thu Jun 04, 2009 11:16 am
by VincentG
any keyboard, or joystick software runing on the system as well?

Re: Strange TIR 5/TCP v5 beta 2 behaviour

Posted: Thu Jun 04, 2009 12:52 pm
by meditek
Of course there is! It's hard to fly without a stick. No keyboard software simply the Hotas Cougar Vista x64 software that runs my controllers. Have you tested the problem yourselves? If you have and have failed to reproduce the problem then I might be persuaded to do some further testing.

Re: Strange TIR 5/TCP v5 beta 2 behaviour

Posted: Thu Jun 04, 2009 4:42 pm
by VincentG
We did some initial testing here, and haven't been able to reproduce.

Re: Strange TIR 5/TCP v5 beta 2 behaviour

Posted: Fri Jun 05, 2009 1:33 am
by meditek
OK. I did some further testing. The fact that you didn't reproduce the problem gave me a thought! Maybe you were using the default view settings? I use modified view settings. In AH you can adjust and save seat and head positions for all the KP views for any particular plane. So I :-

1. Loaded TIR 5 b3

2. Unticked the X,Y & Z axes

3. loaded AH offline Spit VI with my seat settings

4. the views flashed between 'default' and my settings as indicated in my first post.

5. I exited AH and removed the seat setting files (2) from settings/planes which put things back to 'default'.

6. Reloaded AH and problem was gone.

Maybe you could test simply by fully raising the seat view in F1. TIR off, press PgUp, save with F10. You should see the forward view jumping around when you disable xyz axes or even one of them. In this case a reboot did not solve the problem. Similar things happen if you map the KP to new 'seat' settings.

The same problem happens using the TIR 4 software. It would seem to be a problem with the AH interface. I shall ask the technical guys on AH about it too.

Everything works fine with all Axes enabled.

PS There is, of course, an obvious workaround once one has discovered the problem. Simply disable the unwanted axes by flatlining them instead.

Re: Strange TIR 5/TCP v5 beta 2 behaviour

Posted: Fri Jun 05, 2009 12:08 pm
by meditek
The obvious solution failed to work on further online testing.