Optitrack Oculus Rift plugin fails to load in Unreal 4.13.1

Post Reply
Kmack
Posts: 2
Joined: Mon Nov 21, 2016 7:25 pm

Optitrack Oculus Rift plugin fails to load in Unreal 4.13.1

Post by Kmack » Mon Nov 21, 2016 7:46 pm

Hi,
I'm running into the following error when trying to activate the Optitrack Oculus Rift plugin in an Unreal 4.13.1 project built from C++ source:

Missing or incompatible modules in OptitrackOculusRift plugin - would you like to disable it? You will no longer be able to open any assets created using it.

The project then subsequently fails to load, as the plugin can't be loaded. The OptiTrack - NatNet Streaming Client plugin does work correctly and feeds valid data to the application. If I drop the Optitrack Oculus plugin into an off-the-shelf 4.13.2 install from the Epic downloader, it does work. My current suspicion is that the plugin wants to be recompiled so that its version matches that of the custom-built Unreal application, but it appears not to include the source that would be required to do this.

Anybody have any thoughts on what might be going on here?

Thanks!
_Kevin

Kmack
Posts: 2
Joined: Mon Nov 21, 2016 7:25 pm

Re: Optitrack Oculus Rift plugin fails to load in Unreal 4.1

Post by Kmack » Tue Nov 22, 2016 1:17 pm

Update:
I've done the following in an effort to get the plugin built to the same engine version as my application:

Added the OptiTrackOculusRift directory and contents from Plugin_1.3.0_Final.zip to <MyGameDir>\UE4\Engine\Plugins\OptiTrack

Added the plugin to module dependencies in my game's Build.cs:

Code: Select all

using UnrealBuildTool;

public class MyGame : ModuleRules
{
	public MyGame(TargetInfo Target)
	{
		PublicDependencyModuleNames.AddRange(
            new string[] 
            {
                "Core",
                "CoreUObject",
                "Engine",
                "InputCore",
                "OnlineSubsystem",
                "OnlineSubsystemUtils",
                "AssetRegistry",
                "AIModule",
                "HeadMountedDisplay",
                "OptitrackNatnet",
                "OptitrackOculusRift"
            }
        );
	}
}
Regenerated project files, rebuilt the engine, and then rebuilt the game. I'm running into the following error when rebuilding the game, however:

Code: Select all

2>  [39/39] Link UE4Editor-MyGame.dll
2>LINK : fatal error LNK1181: cannot open input file 'E:\Perforce\MyGame\UE4\Engine\Plugins\OptiTrack\OptitrackOculusRift\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-OptitrackOculusRift.lib'
2>ERROR : UBT error : Failed to produce item: E:\Perforce\MyGame\UE4\Engine\Plugins\OptiTrack\OptitrackOculusRift\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-OptitrackOculusRift.exp
Any thoughts on why it's failing here?

Thanks!

Post Reply