Discussion and Support for the OptiTrack, SmartNav and TrackIR brands by NaturalPoint

Unity3D Plugin not working

by HeHeQ » Tue Nov 22, 2016 10:26 am

I am using Unity Plugin 1.0.1 to stream 6DoF HDM (Oculus DK2) to Unity. Without OVRPlugin, the Unity Plugin reports an error saying ovrp_SetTrackingIPDEnabled not found. So I installed OVRPlugin for Unity 5 V1.3.2. But now the HDM does not display the scene. Please help!
my configuration:
windows 7
Unity 5.3.6
Oculus SDK v1.10.0
Oculus Utilities for Unity 5 V1.9.0
OVRPlugin for Unity 5 V1.3.2
Oculus DK2
Posts: 3
Joined: Tue Jun 24, 2014 9:26 pm

by ZachBrockway » Tue Nov 22, 2016 11:51 am

I don't believe it's possible to update OVRPlugin without also updating your Unity version, so it sounds like you may have replaced the plugin with an incompatible version.

"Unity 5.3.6" is only a portion of the full Unity version string, and unfortunately their Oculus integration is very much in flux between patch releases due to being under heavy development. I suspect you're using the "5.3.6f1" release of Unity 5.3.6, which is not new enough to be supported. If you go to the Unity QA patch releases page, you can download patch release Unity 5.3.6p3 or newer, which should work correctly.

Hopefully this helps! Let me know if you're still encountering issues after updating your version of Unity.

Zach Brockway
Senior Software Engineer | NaturalPoint
NaturalPoint Employee
NaturalPoint Employee
Posts: 8
Joined: Wed Oct 21, 2015 9:25 am
Location: Corvallis, OR

by HeHeQ » Sat Dec 03, 2016 7:20 pm

Hi Zach,

I installed Unity 5.3.6p8 as you suggested. The plugin (Unity Plugin 1.0.1) is working now! I get rotation and position data of my DK2 from the server. Thanks! However, there is a very noticeable latency especially when I turn my head. The latency is seen only in DK2. Outside the HMD (e.g.,in game mode inside Unity), the scene is updated without latency. How to fix this issue? Please advise.
Posts: 3
Joined: Tue Jun 24, 2014 9:26 pm

Return to VR