[Unreal4.17] Optitrack Dont setting Initialize HMD Rotation.

Post Reply
ClickMe
Posts: 1
Joined: Thu Dec 14, 2017 6:36 pm

[Unreal4.17] Optitrack Dont setting Initialize HMD Rotation.

Post by ClickMe » Thu Dec 14, 2017 7:09 pm

When Unreal starts,
If you start looking back in the real world, you have to start looking back in the game too,
In the game is looking at the front.

It's the same thing as in 4.17.
I used only the optitrackOrigin and OptitrackPawn on my empty project.
Help me plz.

shinkata
Posts: 2
Joined: Wed May 18, 2016 5:48 pm

Re: [Unreal4.17] Optitrack Dont setting Initialize HMD Rotat

Post by shinkata » Wed Jan 24, 2018 8:11 pm

Me too, but a rigid body with OptiTrack Rigid Body component works fine, translation and rotation.
the problem is the OptiTrackHmdPawn, only works the translation. :roll:

mc_sushi
Posts: 10
Joined: Tue Jan 09, 2018 2:21 pm

Re: [Unreal4.17] Optitrack Dont setting Initialize HMD Rotat

Post by mc_sushi » Thu Jan 25, 2018 4:08 pm

Do you have the OptiTrack - OculusRift plugin enabled in UnrealEngine plugins? Described behavior could happen if the plugin is disabled, or if another plugin used has a higher priority that overrides the control.

yjh
Posts: 3
Joined: Fri Oct 13, 2017 4:40 am

Re: [Unreal4.17] Optitrack Dont setting Initialize HMD Rotat

Post by yjh » Mon Apr 09, 2018 12:08 am

It also happens on our project.
Same project settings including plugin(OptitrackOculusVR On, OculusVR Off) as project on previous plugin & UE4 version (4.13, 4.15, 4.16), but initialization seems not working at all. It also gives no error or warning messages at all.
The only difference I can find between 4.16 ver and 4.17 ver is integration of GearVR and OculusRift plugin into OculusVR. Is that the thing that makes bug of?

Post Reply