Unreal Engine 4 Plugin 1.23 Deprecated Oculus Support?!?

Post Reply
BrunoMartelli
Posts: 36
Joined: Fri Aug 17, 2018 11:15 am
Contact:

Unreal Engine 4 Plugin 1.23 Deprecated Oculus Support?!?

Post by BrunoMartelli » Mon Feb 03, 2020 5:01 am

Hi

I was updating my older Unreal project to 4.23 and got the latest Optitrack plugin (1.23) in notice in the readme it says: - Oculus support deprecated.

What's up with that?

BrunoMartelli
Posts: 36
Joined: Fri Aug 17, 2018 11:15 am
Contact:

Re: Unreal Engine 4 Plugin 1.23 Deprecated Oculus Support?!?

Post by BrunoMartelli » Thu Feb 27, 2020 2:53 am

Hi I was hoping that someone from Naturalpoint would be able to shed some light on the Unreal Plugin & Oculus support going forward? I've asked my mocap equipment supplier, they didn't know about this. (We've got a project coming up will use Optitrack, Unreal, VR and before making purchase decisions about new kit, it would be good to know if we are going to have to use HTC VIVE & not Oculus.) I'm the only person I know working with Optitrack and it sometimes feels like a long and lonely journey into the unknown.

bsteagal
Posts: 314
Joined: Tue Jun 28, 2005 5:00 am
Location: Albuquerque, New Mexico

Re: Unreal Engine 4 Plugin 1.23 Deprecated Oculus Support?!?

Post by bsteagal » Thu Feb 27, 2020 11:35 am

Hi Bruno

I have several customers working with Optitrack and VR equipment, the latest I have is that because of the current difficulties with the Oculus SDK, they are deprecating support for it in favor of Vive and the Valve index, which now have opened up quite a bit to integration. All of my current customers are using Vive.

I know this is not official, and even I don't know what is the official stance, just what I've seen.

Hope this helps?
Bryan Steagall
Owner
Kidz Korner Studio
OptiTrack Distributor
Mexico, Central and South America
505-615-2410
bryan@kkstudio.us
www.kkstudio.us

steven.andrews
NaturalPoint Employee
NaturalPoint Employee
Posts: 590
Joined: Mon Jan 19, 2015 11:52 am

Re: Unreal Engine 4 Plugin 1.23 Deprecated Oculus Support?!?

Post by steven.andrews » Thu Feb 27, 2020 11:40 am

Hi BrunoMartelli,

Thank you for reaching out to the community regarding Oculus support in the Unreal plugin.

We have deprecated Oculus support partially due to the ongoing maintenance burden; Oculus has a track record of breaking our integrations in ways we are not capable of fixing on our end. Oculus has also dropped support for the original Rift, and we do not currently have plans to create a clip for the Rift S.

OpenVR has been good to us, rarely breaking from upstream changes. They have been willing to fix issue in a matter of hours, and the same implementation gives us support for three major HMDs in all game engines and applications. This includes the Vive, Vive Pro and the Valve Index.

Best,
Steven
--
Steven Andrews
OptiTrack | Senior Customer Support Engineer
help.naturalpoint.com
support@optitrack.com

BrunoMartelli
Posts: 36
Joined: Fri Aug 17, 2018 11:15 am
Contact:

Re: Unreal Engine 4 Plugin 1.23 Deprecated Oculus Support?!?

Post by BrunoMartelli » Sun Mar 01, 2020 9:17 am

ok thanks for getting back to me!

BrunoMartelli
Posts: 36
Joined: Fri Aug 17, 2018 11:15 am
Contact:

Re: Unreal Engine 4 Plugin 1.23 Deprecated Oculus Support?!?

Post by BrunoMartelli » Sun Mar 01, 2020 9:19 am

bsteagal wrote:
Thu Feb 27, 2020 11:35 am
Hi Bruno

I have several customers working with Optitrack and VR equipment, the latest I have is that because of the current difficulties with the Oculus SDK, they are deprecating support for it in favor of Vive and the Valve index, which now have opened up quite a bit to integration. All of my current customers are using Vive.

I know this is not official, and even I don't know what is the official stance, just what I've seen.

Hope this helps?
Hi Bryan - thanks for the info, good to know, I've had more than a little pain with Oculus updates etc....But don't you think VIVE is a heavy headset compared to Oculus - or is that me?

BrunoMartelli
Posts: 36
Joined: Fri Aug 17, 2018 11:15 am
Contact:

Re: Unreal Engine 4 Plugin 1.23 Deprecated Oculus Support?!?

Post by BrunoMartelli » Mon Mar 02, 2020 9:06 am

So Steven, I have a follow on question - when you say OpenVR - is this for VIVE exclusively?
(SteamVR which seems to be how Valve and EPIC talk about OpenVR, supports Oculus, are you saying that my Oculus Touches and Optitrack Clips can't work with your OpenVR Driver 2.0.0 ?

steven.andrews
NaturalPoint Employee
NaturalPoint Employee
Posts: 590
Joined: Mon Jan 19, 2015 11:52 am

Re: Unreal Engine 4 Plugin 1.23 Deprecated Oculus Support?!?

Post by steven.andrews » Wed Mar 04, 2020 4:18 pm

The OpenVR Driver will currently work with the Vive, Vive Pro and Valve Index.
We did try to integrate the Oculus, but ran into issues with how they implemented their steamvr integration.

Unfortunately, since we are not developing clips for the new models, we are not likely to continue pursuing Oculus support.

Cheers,
Steven
--
Steven Andrews
OptiTrack | Senior Customer Support Engineer
help.naturalpoint.com
support@optitrack.com

Post Reply