Discussion and Support for the OptiTrack, SmartNav and TrackIR brands by NaturalPoint

TrackIR 5 stopped working in Prepar3D v4

by captainbluesky » Mon Apr 02, 2018 3:24 pm

TrackIR 5 has suddenly stopped working in Prepar3D v4. I have the latest TrackIR 5 version installed. The hat sensors work in the TrackIR software interface (I see the 3 green dots on the dummy's head), the left green light is visible on the hardware, but the right green light does not light up when in Prepar3D v4 with no TrackIR in virtual cockpit etc.

I right click on Chaseplane, TrackIR, SkyForce and Prepar3D and select Run as Admin as standard.

I have tried the recently posted advice below in italics but the problem still remains. I understand this is a fairly common problem.

Please advise:

a) how do I get TrackIR 5 working again asap?

b) will an enhanced update be issued to resolve this problem?

\Lockheed Martin\Prepar3D v4\redist\Interface\FSX-SP1\retail\lib
\Lockheed Martin\Prepar3D v4\redist\Interface\FSX-SP2-XPACK\retail\lib

If they already exist, try running the included MSI files to reset them. Once you have done that, reboot the computer, and then run TrackIR as administrator, and then run the game with administrator privileges as well.
Posts: 3
Joined: Mon Apr 02, 2018 2:46 pm

by captainbluesky » Tue Apr 03, 2018 12:41 pm

Problem solved folks. I had a look at this thread below and followed it step by step. My Track IR suddenly works again in Prepar3D v4. Be sure to methodically find/delete all the "NaturalPoint" and "TrackIR" instances in your Registry Editor as per Steps 7. and 8.

Very strange that Track IR suddenly stopped working (after working fine) but all good now!


Mike Witham got me to do this and it worked

1. Remove TrackIR from add/remove programs
2. Remove NaturalPoint Drivers from add/remove programs.
3. Delete installer executable from where you saved it
4. Delete NaturalPoint folder from Program Files x86
5. Delete NaturalPoint folder from %APPDATA% location.
6. Open regedit.exe as an administrator
7. Search for and delete files labeled as "NaturalPoint"
8. Search for and delete files labeled as "TrackIR"
9. Reboot PC
10. Download new installer from website
11. Right-click and install as an administrator
12. Plug in TrackIR and verify the driver install.
Posts: 3
Joined: Mon Apr 02, 2018 2:46 pm

by captainbluesky » Tue Apr 03, 2018 2:41 pm

I spoke too soon.

I thought I had fixed this.

Now not working again.

Can Support reply re: a fix please?
Posts: 3
Joined: Mon Apr 02, 2018 2:46 pm

by Chris.Johnson » Wed Apr 04, 2018 11:38 am

Hello captainbluesky,

Please contact Support directly at
All the Best,
Chris Johnson
Customer Support Engineer
Posts: 39
Joined: Tue Aug 15, 2017 1:56 pm

Return to TrackIR 5