Page 1 of 2

Trouble calibrating with 6 V100s in CAVE

Posted: Tue Oct 13, 2009 2:35 am
by hpcv
I am trying to get the OptiTrack system working for head tracking in a CAVE. I worked on this project before, but it has been on hold for about two years. I must say that the OptiTrack software has come a long way in the meantime, and I really like the new Tracking Tools compared to the old PC/RB combination. Hot-pluggability of cameras, recording, and less 'linearity' are all great improvements.

However, now I'm having trouble getting a good calibration, and I hope you guys can help me with this.

Our setup is six V100 (R1) cameras, all with the wide-angle 3.5 mm (57.5� FOV) lenses.

The cameras are positioned around the top of a 2,5 by 2,5 by 2,5 metre (~8 foot) cube. The cameras all point towards a point roughly in the centre, but slightly to the back of the cube. Here's a picture, where the centre point of the capture volume is indicated:


The plan is to add two more cameras that look at the space virtually from above, but physically from the side, by using two mirrors (needs to be mirrored twice physically because the software doesn't support mirrored input, right?). Comments on this plan are welcome, but not the main issue right now. I figured it would be better to get this working without that additional complexity first.

There seems to be no frame drop or other hardware problems; the cameras are all running just fine. Synchronization is done through the "classic" daisy-chain method and works fine. The environment is very clean, with no spurious markers at all.

Here's a screenshot of the Tracking Tools right after calibration:


(Unfortunately, it seems there is no longer a way to copy the calibration log, but you can see the last few lines in the screen shot.)

If I apply this 'poor' calibration it turns out to be very poor indeed; the calibrated camera positions are way, way off. Can anyone give some pointers on how to improve these results?

Re: Trouble calibrating with 6 V100s in CAVE

Posted: Tue Oct 13, 2009 9:34 am
by VincentG
A couple of settings, that could be adjusted.

Within the calibration window -

The capture volume is probably a little larger than 1 cubic meter

You have min. camera coverage set to 6 cameras, try decreasing to 5, or even 4.

Also try and get as much of the cameras covered in green as possible (more along the edges)

You can also select all the texxr, under the calibration engine, and save it as a txt file.

Re: Trouble calibrating with 6 V100s in CAVE

Posted: Thu Oct 15, 2009 6:54 am
by hpcv
Thanks for the advice!

More coverage along the edges was probably the problem. This was not possible before, because (you might not be able to tell this from the picture) cameras 3 and 4 are on their side, but the rest is upright. Because of this, I could not get coverage from more than two cameras in some regions. I now put all cameras on their side, and that helped a lot.

I also set the capture volume to 3 cubic metres and decreased the minimum coverage to 4.

Here are some questions and/or points for improvement of this beta:

1. It is not clear which approximate capture volume you should choose when you are in between. It would be better to list some ranges, e.g. less than 2 cubic metres, 2-4, 4-6, more than 6.

2. The "wanding time" option is also unclear. If I set this to 300 seconds, I still do not get the time to achieve full coverage in all camera images. It seems to stop when a certain number of points have been acquired (254?).

3. Finally, I did not manage to save the calibration output. This used to be a text field (which allows selecting and copying), but is now a list box. It allows multi-select, but there seems to be no way to do anything with the selection.

Re: Trouble calibrating with 6 V100s in CAVE

Posted: Thu Oct 15, 2009 8:21 am
by hpcv
I found a workaround for issue #2 above: set frame decimation to capture every eighth frame. That gives me some more time to achieve proper coverage of the camera images.

However, calibration is still no go:


Any suggestions as to what is going wrong here, and what else I could try?

Re: Trouble calibrating with 6 V100s in CAVE

Posted: Thu Oct 15, 2009 12:32 pm
by VincentG
Which beta application are you using?

Re: Trouble calibrating with 6 V100s in CAVE

Posted: Fri Oct 16, 2009 9:17 am
by hpcv
Judging from the date I downloaded, I think it is beta 3. The changelog entry "Accommodates longer wanding durations" for beta 4 (the current latest version) supports this hypothesis.

I'll check next week to make sure.

Re: Trouble calibrating with 6 V100s in CAVE

Posted: Tue Oct 20, 2009 6:04 am
by hpcv
The About dialog in the Tracking Tools doesn't mention the exact version; it just said "Version 2.00 Beta". It's Build #6232, dated July 28.

I now downloaded and installed Beta 4, and that is Build #6445, dated October 7. I'll try again with the new version and report the results here. Thanks!

Re: Trouble calibrating with 6 V100s in CAVE

Posted: Tue Oct 20, 2009 6:33 am
by hpcv
New software, same old trouble. Longer wanding time works well, though... I don't need the decimation trick anymore, so I can make do with 120 seconds of wanding time to fill the frames nicely:


But I just noticed something. In this screenshot and the one above, you can see there is a marker exactly in the top left corner of every camera image.

Judging from the opacity, this could even be more than 1 marker, overlapping. It is only the top left corner; this never happens in the other corners. This point doesn't show up as a spurious marker during wanding.

Could this be a bug?

Re: Trouble calibrating with 6 V100s in CAVE

Posted: Tue Oct 20, 2009 7:50 am
by hpcv
I am now pretty sure that this is indeed a bug. Look at these two screenshots:

Before clicking Calculate (cropped because of image size limits):


Observe that the wanding curve does not touch the upper left corner of most camera images.

After clicking Calculate:


Note the bright green diamonds in the upper left corner of every image. Also note that the program crashed...

Could it be that points not registered by all cameras (e.g. only 4 out of 6) are still drawn in all 6 images, with a default location of (0,0) for cameras that did not register the point? That would be somewhat confusing, but otherwise harmless.

Update: indeed, if I tell the software to require points to be visible on all 6 cameras, the mysterious upper-left-corner points are gone.

Re: Trouble calibrating with 6 V100s in CAVE

Posted: Tue Oct 20, 2009 11:24 am
by beckdo

First off, the upper left corner markers denote samples where the camera had no visible markers--this is basically a non-point and is not included in the calibration calculation. Now that you've mentioned it and it's clearly a point of confusion, I will make sure those aren't drawn.

That wanding looks flawless. Can you record a wanding and send the timelime file to I would like to use your recorded wanding to see the calibration result myself. Also any additional information on why the application crashed would be great. This is news to me.