TrackIR 4 Pro on Windows 10

Post Reply
Posts: 1
Joined: Fri Oct 16, 2015 10:29 pm

TrackIR 4 Pro on Windows 10

Post by FPascal4 » Fri Oct 16, 2015 10:43 pm

I have a TrackIR 4 Pro that I have had for several years. I recently upgraded to Windows 10 64 bit and I want to use my TrackIR 4 Pro with Space Citizen. I tried installing the latest 5.2.2 Final from the drivers page, using the 64bit driver. The driver appears to install fine, but when I reboot or plug my TrackIR 4 Pro in, it comes up in the device manger as "Unknown USB Device (Device Descriptor Request Failed). I have tried plugging into a different USB port and got the same error. I verified that the driver is installed, even tried reinstalling by pointing to the actual install directory where the drivers were installed - no luck.

It's been a while since I have used this device, long enough that I have changed complete machines under it moving up to an Asus Rampage V Extream motherboard. I haven't seen it operational since I used the previous machine.

Should my TrackIR 4 Pro work with Windows 10 64bit on this motherboard? If yes, could you point me to what I can check? Are there newer drivers than the 5.2.2 Final dated waaaaaay back in 2013?

NaturalPoint Employee
NaturalPoint Employee
Posts: 1477
Joined: Mon Nov 04, 2013 10:19 am

Re: TrackIR 4 Pro on Windows 10

Post by MikeWitham » Mon Oct 19, 2015 11:49 am


The device should work on Windows 10 with no issues. Code 43 or "Device Descriptor Request Failed" means that the hardware can not communicate well, and that's usually due to chipset drivers. Either a bad install, or an outdated driver on the PCs side. Are all of your motherboard drivers up to date?

It could be power related. Do you have a powered USB hub that you could test the device with?

Mike Witham
TrackIR Product Manager

Post Reply